HPEスイッチ 基本コマンド&初期設定例 ~VLAN/リンクアグリゲーション(LACP), ssh, snmp, ntp, syslog等の管理設定,debug~

HP5130 等の基本設定方法をまとめてみました。なお、設定削除は設定内容の前に undo を付けるだけで大体対応可能。

現在のconfigを見る

<HPE> current-configuration

Configurationモードになる

<HPE> system-view

ホスト名を設定

[HPE] sysname HOGE

configを保存

[HOGE] save

VLANを設定

vlan 2 を作り、vlan 5 から 10 をまとめて作り、gi 1/0/1 インタフェースにアクセス vlan 2 を割り当て、gi 1/0/2 インタフェースにトランク vlan 5,6,8 を割り当て、vlan-interface 2 に IP アドレス 192.168.0.1/24 を割り当てる。

[HOGE] vlan 2
[HOGE-vlan-2] quit
[HOGE] vlan 5 to 10
[HOGE-vlan-5to10] quit
[HOGE] int giga-1/0/1
[HOGE-int-giga-1/0/1] port access vlan 2
[HOGE-int-giga-1/0/1] quit
[HOGE] int giga 1/0/2
[HOGE-int-giga-1/0/2] port link-type trunk
[HOGE-int-giga-1/0/2] port trunk permit vlan 5 to 6 8
[HOGE-int-giga-1/0/2] quit
[HOGE] int vlan 2
[HOGE-interface-vlan-interface2] ip address 192.168.0.1 255.255.255.0

現在入っているインタフェースの設定状態を見る

[HOGE] interface giga 1/0/1
[HOGE-int-giga-1/0/1] display this
interface gigabitEthernet 1/0/1
port access vlan 2
[HOGE-int-giga-1/0/1]

インタフェースのLink UP/DOWN状態等を一覧表示

[HOGE] display interface brief

SSH設定

[HOGE] line vty 0 7
[HOGE-line-vty-0-7] authentication-mode scheme
[HOGE-line-vty-0-7] user-role network-admin
[HOGE-line-vty-0-7] quit
[HOGE] local-user myadmin class manage
[HOGE-local-user] password simple ***
[HOGE-local-user] service-type ssh terminal
[HOGE-local-user] authrization-attribute user-role network-admin
[HOGE-local-user] quit
[HOGE] ssh server enable

ACL 設定

ACL をインタフェースへの INBOUND/OUTBOUND のアクセス制御に使う

[HOGE] acl number 2000
[HOGE-acl-2000] rule 10 permit source 172.16.1.0 0.0.0.255
[HOGE-acl-2000] quit
[HOGE] interface vlan 5
[HOGE-int-vlan5] packet-filter inbound 2000
[HOGE-int-vlan5] packet-filter outbound 2000

ACL を SSH のアクセス制御に使う

[HOGE] acl number 2001
[HOGE-acl-2000] rule 10 permit source 10.1.1.0 0.0.0.255
[HOGE-acl-2000] quit
[HOGE] ssh server acl 2001

ルーティング設定

デフォルトルート設定 (0.0.0.0 の後の 0 はサブネットマスク 0.0.0.0 の意味)

[HOGE] route-static 0.0.0.0 0 192.168.0.254

通常のスタティックルートも同じ

[HOGE] ip route-static 10.0.0.0 255.0.0.0 192.168.0.254

ntp/時刻設定

タイムゾーン

[HOGE] clock timezone JST add 09:00:00

時刻同期を手動で実施

[HOGE] clock protocol none
[HOGE] quit
clock datetime 8:58:28 5/28/2018

NTP で時刻同期 (clock protocol none だと時刻同期できない)

[HOGE] clock protocol ntp
[HOGE] ntp-service enable
[HOGE] ntp-service unicast-server 192.168.3.1

SNMP設定(v2c)

[HOGE] snmp-agent
[HOGE] snmp-agent community read examplepublic
[HOGE] snmp-agent community write exampleprivate
[HOGE] snmp-agent sysinfo version v2c
[HOGE] snmp-agent target-host trap address udp-domain 192.168.2.1 params securityname examplepublic v2c
[HOGE] snmp-agent trap enable arp
[HOGE] snmp-agent trap enable radius

syslog設定

[HOGE] info-center loghost 192.168.1.1
[HOGE] info-center loghost 192.168.1.2

その他確認したほうがよい設定

ttl-expires と unreachable は有効化、redirects は無効でよい。

[HOGE] undo ip redirects enable
[HOGE] ip ttl-expires enable
[HOGE] ip unreachables enable

STP は今時使わないでしょ

[HOGE] undo stp global enable

代わりに LoopbackDetection を入れよう (アップリンクには入れない方がよい)

[HOGE] int giga 1/0/1
[HOGE-int-giga-1/0/1] loopback-detection enable vlan 1 to 4094
[HOGE-int-giga-1/0/1] loopback-detection action block

アップリンクに入れるとタイミングが悪いとアップリンクへの通信が全断になるからね。

設定状態確認

[HOGE] display loopback-detection

リンクアグリゲーション(Bridge-Aggregation)

ブリッジアグリゲーションと呼ぶ。グループは LAG ではなく BAGG だと。

まず論理 BridgeAggregation インタフェースを作って、いったん抜けて、BAGG に所属させたいインタフェースに入ってそのグループ番号を設定して、抜けて、もう 1 回 BridgeAggregation インタフェースに入って trunk とかの設定をしていけばグループのインタフェース全部に反映される。

[HOGE] int bri 9
[HOGE-int-Bridge9] description BAG9DAYO
[HOGE-int-Bridge9] quit
[HOGE] int giga 1/0/9
[HOGE-int-giga-1/0/9] description GIGA1/0/9
[HOGE-int-giga-1/0/9] port link-aggregation group 9
[HOGE-int-giga-1/0/9] quit
[HOGE] int giga 2/0/9
[HOGE-int-giga-2/0/9] description GIGA1/0/9
[HOGE-int-giga-2/0/9] port link-aggregation group 9
[HOGE-int-giga-2/0/9] quit
[HOGE] int bri 9
[HOGE-int-Bridge9] port link-type trunk
[HOGE-int-Bridge9] port trunk permit vlan 5 to 10

Static (Cisco でいう mode on) の場合は上記でOK。LACP (802.3ad/802.1ax) を使う場合はさらに以下を設定

[HOGE-int-Bridge9] link-aggregation mode dynamic

設定状態確認

[HOGE] display link-aggregation summary

デバッグの仕方

SSH をした状態でデバッグするには以下を実施

<HOGE> terminal monitor
<HOGE> terminal debugging
<HOGE> debug ip rip

ログの確認

直近のログを見たい場合は以下のようにreverseを付ける。

[HOGE] display logbuffer reverse

reverse を付けない場合は一番古いログから順番に表示される。

IT/インフラエンジニアの地位とスキル向上のために

関連記事

IT 技術の進化はとどまることを知りません。矢継ぎ早に新たな技術が出てきたり、数年前の技術が時代遅れになったりと、IT エンジニアは勉強し続ける運命のようです。 それをどう思うかはあなた次第。 ビジネスの基本は『付加価値を与える[…]

IMG
関連記事

nesuke の考える NW エンジニアの2つの道 ネットワークエンジニアには 2 つの道があります。 1 つはネットワーク構築一筋で、L4 までをひたすらきっちりと構築していく道。 もう 1 つはネットワークを軸として深堀し[…]

IMG