Configuration of MPLS-VPN (Super Backbone and Sham-Link)

About Super BackBone

Super backbone, as had you seen before, when you redistribute the OSPF through the MPLS-VPN, is the ability to redistribute in LSA Type 3 instead of the LSA Type 5.

Although often described as "the same as the area 0" will be made, as you saw in the example, it will be the area 0 to each other in the LSA Type3 be connected by MPLS Super BackBone, not be said to be "the same as the area 0" Hmm.

However, connecting such area 0 to each other via the MPLS-VPN, because is not common can say is that it is a special case. Normal configuration is as follows.

Conditions to operate as a super backbone, is that when you redistribute the OSPF routes in the MP-BGP, which is an extended community of the Path Attribute Type 16 "Domain-ID" is the same as the Domain-ID of the OSPF process of the counter. And if the OSPF process ID is the same, the Domain-ID will be the same. In addition, manually set of the command is also available following (command to set the domain ID = 10).

(config)# router ospf 1 vrf VPN_A
(config-router)# domain-id 10

It should be noted that the extended community there is a Route Type and Route ID as used the way other than the Route-Target. This is the time to redistribute from OSPF to MP-BGP, it will be propagated along with the VPNv4 Prefix and Route-Target.

Route Type community is made up of [Area ID (4byte)] + [Route Type (1byte)] + [Option (1byte)]. Route Type is written or network information to be transmitted is derived from what number of LSA Type of OSPF is. The possible values ​​will be [1,2,3,5,7,129]. Respectively [LSA Type1, LSA Type2, LSA Type3, LSA Type5, LSA Type7, Sham-Link]. The last of the [Option] means or E1 or E2 in Type5 or Type7. (E1 = 0, E2 = 1)

Route Type community is made up of [Area ID (4byte)] + [Route Type (1byte)] + [Option (1byte)].

Route Type is written or network information to be transmitted is derived from what number of LSA Type of OSPF is. The possible values ​​will be [1,2,3,5,7,129]. Respectively [LSA Type1, LSA Type2, LSA Type3, LSA Type5, LSA Type7, Sham-Link]. The last of the [Option] means or E1 or E2 in Type5 or Type7. (E1 = 0, E2 = 1)

BGP of Update Sometimes the following message from PE2 to PE1 is exchanged. In four of the route, (from CE1-2 to CE1-1, the root of 10.2.23.0 / 24) only one has been described.

Since the Domain ID was using the process ID = 10 is between CE1-1 and CE2-1 in the previous example, it has become a super backbone but, CE1-2 and in between CE2-2 with each process ID = 20 30 and using, not turned in its order super backbone.

About Sham-Link

In the Super backbone could not only to re-distribution in the LSA Type3, but by using a feature called Sham-Link (structural link), you can pass the LSA Type1 and 2 on a MPLS-VPN.

To configure the Sham-Link is, the Loopback address to the PE router at both ends created on the VRF first, and distribute the route in BGP. Then, you put a set of Sham-Link in the OSPF process.

[Configuration of PE1]

PE1(config)# interface loopback 11
PE1(config-if)# ip vrf forwarding VPN_A
PE1(config-if)# ip address 11.1.1.1 255.255.255.255
PE1(config)# router bgp 65001
PE1(config-router)# address-family ipv4 vrf VPN_A
PE1(config-router-af)# network 11.1.1.1 mask 255.255.255.255
PE1(config)# router ospf 10
PE1(config-router)# area 0 sham-link 11.1.1.1 22.2.2.2

[Configuration of PE2]

PE2(config)# interface loopback 22
PE2(config-if)# ip vrf forwarding VPN_A
PE2(config-if)# ip address 22.2.2.2 255.255.255.255
PE2(config)# router bgp 65001
PE2(config-router)# address-family ipv4 vrf VPN_A
PE2(config-router-af)# network 22.2.2.2 mask 255.255.255.255
PE2(config)# router ospf 10
PE2(config-router)# area 0 sham-link 22.2.2.2 11.1.1.1

Make sure of link state of Sham Link.

PE1/PE2 # show ip ospf sham-links

Result of show command : PE1 / PE2

When you put this setting, it is assumed that the PE1 and PE2 is directly connected, you can do the OSPF of exchange of unicast (All of Hello ⇒ DBD ⇒ LSRequest ⇒ LSUpdate ⇒ LSAck) in 11.1.1.1 and 22.2.2.2 .

It should be noted that, Sham Link is be different from the domain ID can be configured without any problems